SAP Solution Manager Adapter for SAP Quality Center by HP
How-to guide for SAP Solution Manager 7.1

November 2011
# Table of Contents

1. **Introduction** .......................................................................................................................... 1

2. **Product Download** .............................................................................................................. 3
   2.1 Support Pack 14 and higher ................................................................................................... 3
   2.2 SAP Quality Center adapter for SAP Quality Center by HP ........................................... 4
   2.3 HP Enterprise Edition ......................................................................................................... 6

3. **Prerequisites** .......................................................................................................................... 7
   3.1 Blueprint data exchange configuration in SAP Solution Manager ..................................... 9
   3.2 Defect exchange configuration in SAP Solution Manager ................................................ 10
   3.3 Field mapping in SAP Quality Center by HP .................................................................... 10

4. **Step-by-Step Procedure** ....................................................................................................... 12
   4.1 Associate SAP Solution Manager Project with SAP Quality Center by HP Project .......... 12
   4.2 Send a Blueprint from SAP Solution Manager to SAP Quality Center by HP .................. 13
   4.3 Send Test Results from SAP Quality Center by HP to SAP Solution Manager .............. 17
   4.4 Filing Defect in SAP Quality Center by HP and sending it to SAP Solution Manager .... 19
   4.5 Resolving defect in SAP Solution Manager and Sending it to SAP Quality Center by HP ... 21
   4.6 Reporting in SAP Quality Center by HP .......................................................................... 23
   4.7 Reporting in SAP Solution Manager ................................................................................. 26

5. **Appendix** ............................................................................................................................... 29
   5.1 Detailed Step for Adapter Configuration ............................................................................. 29
      5.1.1 Integration Test Management ....................................................................................... 29
      5.1.2 Integration Defect Management ................................................................................... 48
   5.2 Adapter Configuration Checklist ......................................................................................... 59
   5.3 Assignment of user to SAP Quality Center by HP project ............................................... 61
   5.4 Solution Manager Blueprint Trash in SAP Quality Center by HP .................................. 62
   5.5 Mapping new fields for defects exchange ......................................................................... 63
   5.6 Relevant Notes ..................................................................................................................... 63
   5.7 Troubleshooting Adapter .................................................................................................... 63
   5.8 Additional Information ......................................................................................................... 66
1. Introduction

Any change to your solution landscape requires testing to ensure software quality and minimize business and IT risk. But since so many testing tasks require manual effort, quality assurance teams find themselves pressed for time. To stay on schedule, teams must often either delay the release or skip critical tests. Either option results in higher cost or a riskier quality process.

To address this challenge, SAP has developed an adapter that integrates the SAP Solution Manager Application management solution and the SAP Quality Center application by HP, used for software testing. This allows you to transfer your business blueprint structure and related documents, specifications, business requirements, links, and test objects such as transactions, implementation guide activities, or custom programs. Quality managers use this information to plan and structure their test projects efficiently. Integration between the service desk of SAP Solution Manager and the defect management of SAP Quality Center makes test execution faster and more transparent.

Integration between the tools lets testing teams work in their familiar environment because information for one application is made visible in the other, your IT staff doesn't have to master separate testing tools, and you have a far more efficient testing process that improves software quality and reliability. Testing is standardized and integrated project wide, and information is consolidated in a single view to support informed release decisions. The efficiency you gain can reduce costs and, more importantly, help minimize the risk of outages and other problems caused by poor testing.

To speed up testing and improve software quality, you can transfer business blueprints and test assets from the SAP Solution Manager Application management solution to the SAP Quality Center application by HP. You can then test in SAP Quality Center, display the results in SAP Solution Manager, and synchronize your quality center defects with service desk tickets.
In the Figure 2, we would notice that SAP TAO (Test Acceleration and Optimization) could also be used to quicken the testing process. Once Business Requirement gets transferred from SAP Solution Manager, test case could be easily created by smaller building blocks called components.

SAP Test Acceleration and Optimization helps QA specialists to break down an application into components which are:

- Assembled into test cases through a simple interface using drag and drop
- Parameterized for flexible reuse, such as reusing a test that has updated data inputs
- Maintained easily and inexpensively, even when screens, flows, or service packs change.

SAP TAO has strong integration with HP Quick Test Professional (QTP), and generates QTP script in background. Quick Test Professional (QTP) is an automated functional Graphical User Interface (GUI) testing tool created by the HP subsidiary Mercury Interactive that allows the automation of user actions on a web or client based computer application. It is primarily used for functional regression test automation. QTP uses a scripting language built on top of VBScript to specify the test procedure, and to manipulate the objects and controls of the application under test.

SAP Test Acceleration and Optimization is designed for SAP-GUI-based applications. SAP Test Acceleration and Optimization users should be experienced quality administrators who are familiar with the SAP Quality Center by HP (also referred to as HP Quality Center), SAP GUI ERP applications, and business process testing.

Overall, SAP Quality Center by HP along with specialized tools like SAP TAO makes testing process easier.
2. Product Download

To install the adapter several pieces need to be installed:

- Solution Manager 7.0 SP14 and above: (SP17 is recommended)
  SP18 includes Service Desk/Defect Management Integration
- SAP Solution Manager Adapter for SAP Quality Center by HP
- HP Enterprise Integration to be installed over SAP Quality Center by HP

2.1 Support Pack 14 and higher

- For Netweaver 2004s, all Support packages will be installed via the Maintenance Optimizer
- Please find more information at https://service.sap.com/solman-mopz

Maintenance Optimizer

Process for Support Package Stack
2.2 **SAP Quality Center adapter for SAP Quality Center by HP**

On Solution Manager 7.0, SP14 or higher, the SAP Adapter for QC needs to be installed. This can be found at: [http://service.sap.com/swdc](http://service.sap.com/swdc) after this adapter was acquired from SAP. Please contact your Client Partner for any questions about this.

1. Select on the left “Search for all Categories” and enter “QC Adapter” in the search term field.

2. Select “SAP ADAPTER FOR QC 1.0” to get to the download link.

3. Download and install the “Addon Installation to Solution Manager”
4. Select Installation

**SAP Software Distribution Center**

**SAP ADAPTER FOR QC 1.0**

- Installation

**Downloads**

**SAP ADAPTER FOR QC 1.0**

You can download one or more files by activating the check box on the left and clicking the button “Add to Download Basket”. Please [click here for more detailed information](#). Click on [![](button.png)](button.png) to request side effects report.

<table>
<thead>
<tr>
<th>File Type</th>
<th>Download Object</th>
<th>Title</th>
<th>Info File Size [kb]</th>
</tr>
</thead>
<tbody>
<tr>
<td>SAR</td>
<td>SAMPITLHRA</td>
<td>ST-ODA 100: AD-ON Installation</td>
<td>Info 2</td>
</tr>
</tbody>
</table>

[Add to Download Basket](#)  [Maintain Download Basket](#)  [Select All](#)  [Deselect All](#)

---

**Downloading SAP Adapter for QC 1.0 at Service Market Place**
2.3 HP Enterprise Edition

HP Enterprise edition needs to be installed on SAP Quality Center by HP and its dependent on the service pack level of SAP Solution manager. The following table explains the dependency.

<table>
<thead>
<tr>
<th>SAP Solution Manager Service Pack</th>
<th>SAP Quality Center by HP Version</th>
<th>HP Enterprise Integration Version</th>
</tr>
</thead>
<tbody>
<tr>
<td>SP 14 to SP 17</td>
<td>9.2 Patch 6 or Later</td>
<td>2.0</td>
</tr>
<tr>
<td>SP 18 and above</td>
<td>9.2 Patch 17 or Later</td>
<td>2.1</td>
</tr>
<tr>
<td>SP 18 and above</td>
<td>10 Patch 4 or Later</td>
<td>2.5</td>
</tr>
<tr>
<td>SP 18 and above</td>
<td>11 Patch 1 or Later</td>
<td>2.6</td>
</tr>
</tbody>
</table>

HP Enterprise Integration 2.0 could be installed on SAP Quality Center by HP 9.2 Patch 6 or later, while HP Enterprise Integration 2.1 could be installed on SAP Quality Center by HP Patch 17 or later.

To download HP Enterprise integration 2.0 and 2.1, visit the following link,


To download HP Enterprise Integration 2.5, visit the following link,


To download HP Enterprise Integration 2.6, visit the following link,

3. Prerequisites

For SAP Solution Manager and SAP Quality Center to exchange information, following configurations are required:-

1. Field mapping of mandatory fields of SAP Solution Manager with SAP Quality Center by HP.
2. Blueprint exchange configuration: The following configuration is needed to be done for exchange of blueprint information.
   a. **Specify Logical Port**: The Logical Port specifies the server on which SAP Quality Center by HP is installed. It is used to transfer data to the HP Quality Center.
   b. **Setup Communication User for Quality Center**: You must set-up a user in Quality Center and assign it to the Quality Center projects, for communication with SAP Quality Center by HP. The technical user is only needed by the Solution Manager system, to connect the Solution Manager project and the Quality Center project.
   c. **Set Up Technical User for Web Service**: This activity creates a technical user with restricted authorization. This user is used to access the Web Service with which the Quality Center sends test results to the Solution Manager system.
   d. **Create Technical User for Alias**: This activity creates a technical user for WSDL access in a subsequent configuration step with Restricted Authorization.
   e. **Release Web Service for Test Results**: This activity releases a Web Service which is used by the Quality Center to send test results to the Solution Manager system. An external alias is automatically created for it.
   f. **Activate Service and Create Alias**: A service is activated and assigned it an external alias.
   g. **Activate Service to Display Solution Manager Documents in QC**: SAP Solution Manager System documents are displayed by link in the Quality Center. You must activate a service to make this possible.
   h. **Connect to SAP Quality Center by HP**: It is used to associate a SAP Solution Manager project with SAP Quality Center by HP Project. It is explained in detail in 3.1.
   i. **Set up Batch Jobs**: The test object and the logical component from the Solution Manager are sent to the Quality Center, so that it knows in which system to test. The Quality Center sends the test results, with the logical components, the role and system names and their clients, to the Solution Manager. If you want to refresh the data automatically, schedule the report RS_SM_QC_REQUIREMENT_SYNC. If this return is to be automatic, schedule the report RS_SM_QC_TESTRESULT_SYNC.

<table>
<thead>
<tr>
<th>Configuration for Outbound communication from SAP Solution Manager</th>
<th>Configuration for Inbound Configuration to Solution Manager</th>
</tr>
</thead>
<tbody>
<tr>
<td>Specify Logical Port</td>
<td>Set Up Technical User for Web Service</td>
</tr>
<tr>
<td>Setup Communication User for Quality Center</td>
<td>Create Technical User for Alias</td>
</tr>
<tr>
<td></td>
<td>Release Web Service for Test Results</td>
</tr>
<tr>
<td></td>
<td>Activate Service and Create Alias</td>
</tr>
<tr>
<td>Activate Service to Display Solution Manager Documents in QC</td>
<td>Connect to SAP Quality Center by HP</td>
</tr>
<tr>
<td></td>
<td>Set up Batch Jobs</td>
</tr>
</tbody>
</table>

© 2011 SAP AG
3. Defect exchange configuration: Following defect exchange configuration is needed to be done in IMG,
   a. **Create Logical Port for Standard Interface**: The logical port is used to transfer defect related data using Standard Interface.
   b. **Create Logical Port for Quality Center Extension**: The logical port is used to transfer defect related data using special Quality Center interface.
   c. **Create Technical User**: Create a technical user via which data can be sent from SAP Quality Center by HP to the Solution Manager system
   d. **Release Web Service for External Service Desk**: This IMG activity releases a web service for the standard Service Desk, and a Communication user for the web service must be created before this step.
   e. **Release Web Service for Enhance Service Desk Interface**: This IMG activity releases a web service for the extended Service Desk, and a Communication user for the web service must be created before this step.
   f. **Adapt Status Profile for Transaction Type SMIN**: You must adjust the status schema for the transaction type SMIN (default) for the integration between Solution Manager Service Desk messages and Defect Management
   g. **Assign Web Service Configurations to External Test Tool**: All the test and defect management configurations are grouped together.
   h. **Assign Field Values in Quality Center System**: To mapping of defect fields of SAP Quality Center with fields of an incident of SAP Solution Manager. The mapping is done in SAP Quality Center.
   i. **Schedule Background Job for System Synchronization**: To ensure that the Quality Center system can effectively synchronize defects with incidents in the Solution Manager Service Desk, you need to enter information about the corresponding SAP system, client, and relevant application component in the Quality Center. If a Solution Manager project is linked to a Quality Center project, the system automatically transfers to Defect Management the list of the application components used in the Solution Manager Service Desk as well as the systems of a Solution Manager project. This excludes all systems with the system role production system. At a later time, you can trigger another transfer by opening and confirming the assignment dialog.

<table>
<thead>
<tr>
<th>Configuration for Outbound communication from SAP Solution Manager</th>
<th>Configuration for Inbound Configuration to Solution Manager</th>
</tr>
</thead>
<tbody>
<tr>
<td>Create Logical Port for Standard Interface</td>
<td>Create Technical User</td>
</tr>
<tr>
<td>Create Logical Port for Quality Center Extension</td>
<td>Release Web Service for External Service Desk</td>
</tr>
<tr>
<td></td>
<td>Release Web Service for Enhance Service Desk Interface</td>
</tr>
<tr>
<td></td>
<td>Adapt Status Profile for Transaction Type SMIN</td>
</tr>
<tr>
<td>Assign Web Service Configurations to External Test Tool</td>
<td>Assign Field Values in Quality Center System</td>
</tr>
<tr>
<td></td>
<td>Schedule Background Job for System Synchronization</td>
</tr>
</tbody>
</table>
3.1 Blueprint data exchange configuration in SAP Solution Manager

You can configure the SAP Solution Manager system using the Implementation Guide (IMG) in the system as follows:

1. In the SAP Solution Manager System Easy Access menu: Tools, Customizing, IMG, execute project) choose Tools->Customizing->Execute project (transaction SPRO).
2. Choose the respective IMG Project and open it
3. Choose SAP Solution Manager Implementation Guide ->SAP Solution Manager
4. Execute IMG Activity Configuration-> SAP Customizing Implementation Guide ->Activate Business Functions
5. Activate Enterprise Extension SM_QC_AD SAP Adapter for Quality Center.

6. Start the configuration of the SAP Solution Manager adapter for SAP Quality Center by HP which can be found at SAP Solution Manager ->Capabilities (Optional) ->Test Management->External Integration->SAP Quality Center by HP Integration.
7. Click on Integration SAP Quality Center by HP Integration: Test Management.

8. The details about configuration could be obtained by clicking on the icon next to each IMG activity and once the configuration is done, will appear.
### 3.2 Defect exchange configuration in SAP Solution Manager

Follow step 1 to 6 of section 2.2.

1. Click on Integration Test Management.

   ![Defect Management Integration Configuration](image)

   Defect Management Integration Configuration

2. The details about configuration could be obtained by clicking on ![symbol] and once the configuration will be complete, ![symbol] will appear.

### 3.3 Field mapping in SAP Quality Center by HP

The field mapping of mandatory field of solution manager which are “Reported By” and “Priority” is required. It is also absolutely needed to have append only functionality for writing defect comments as deletion of the existing comments in the solution manager is not allowed.

The following steps explain the process of doing field mapping.

1. Logon to HP Quality Center by providing user credentials, Domain and Project.
2. Go to Tools->SAP Tools->Field Mapping.

   ![Field Mapping](image)

   Field Mapping
3. Check “Apply Append only mode to defect comments”

Field Mapping of mandatory fields

4. Do field mapping of HP Quality Center field “Detected by” to SAP Solution Manager field “Reported By”.

5. Do field mapping of HP Quality Center field “Severity” to SAP Solution Manager field “Priority”.

6. Individual values of Severity and priority is mapped using “Value Mapping” button.
4. Step-by-Step Procedure

4.1 Associate SAP Solution Manager Project with SAP Quality Center by HP Project

1. Go to Implementation/Upgrade Work center->Projects and select the desired project, e.g. O2C_OPT2 and click on Display. Click on .
2. Click on Menu: Edit->Connection to SAP Quality Center by HP and enter the SAP Quality Center by HP project.

![Change Project - O2C_OPT2 - SAP Solution Manager](image)

3. Go to Project Standard->Tabs->Transfer to SAP QC by HP, and make it visible in Blueprint Visibility and Configuration Visibility. Click on .
4.2 Send a Blueprint from SAP Solution Manager to SAP Quality Center by HP

This section explains the steps to send blueprint from SAP Solution Manager to SAP Quality Center by HP.

List of elements which are transferred from SAP Solution Manager to SAP Quality Center by HP are:

- Blueprint structure elements which have at least one entry assigned on the tab 'Transfer to SAP QC by HP'
- For these structure elements, all the documents placed in General Documentation tab, Training Material tab and Project Documentation tab will be transferred as URL in order to be reachable via a browser.
- Objects from any of the following tab can be added to AP QC by HP tab:
  - the Configuration tab,
  - Development tab,
  - Training Material tab,
  - Project Documentation tab
- The objects (Business Requirement or Test Objects) located on the SAP QC by HP tab are transferred.
- For Administration tab, only the keyword information is passed to SAP Quality Center by HP.

The test objects are passed by putting them in SAP Quality Center by HP tab. They could be passed in two following ways:

1. Test object which are associated with a Business requirement document.
2. Test object directly being put in the tab: Test object which are present in Transaction, Configuration or Development tab could be directly added, without associating it with any business requirement document.

The following table explains the mapping of the data which is transferred from SAP Solution Manager to SAP Quality Center by HP.

<table>
<thead>
<tr>
<th>SAP Solution Manager</th>
<th>SAP Quality Center by HP</th>
</tr>
</thead>
<tbody>
<tr>
<td>Admin Tab</td>
<td>Details (Right Click on a tree element, and select “Requirement Details”)</td>
</tr>
<tr>
<td>General Tab</td>
<td>Attachments</td>
</tr>
<tr>
<td>Project Tab</td>
<td>Attachments</td>
</tr>
<tr>
<td>SAP QC by HP Tab</td>
<td>Business Requirement (The document passed comes as an attachment).</td>
</tr>
<tr>
<td>Test Object</td>
<td>Test Requirement</td>
</tr>
</tbody>
</table>

Only documents or test objects attached in SAP QC by HP Tab become business requirements or test requirements in SAP Quality Center by HP.

1. Navigate to “Test Management” work center
   a. Click on Test Preparation->Project
   b. Select the desired project, e.g. O2C_OPT2
   c. Click on Goto->Business Blueprint.
Test Management Work center


   The uploaded document could be viewed by clicking on.

4. Click on tab “Send to SAP QC by HP” and add the business requirement document uploaded in “Proj. Documentation” tab, using button.

5. After addition of the document, select the document and click.
   a. “Maintain attributes” window will appear
   b. Click on “Test Object” Tab of this window.
   c. Click on add button, and list of objects which could be added would appear. The list built from objects present in the Transaction, Development and Configuration tab of Solar01 and Solar02 transaction.

Test object added to a Requirement Document
6. Click on the menu Business Blueprint -> Send Data to Quality Center and select all the business processes.

![Business Blueprint menu](image)

Sending Data to HP Quality Center from SAP Solution Manager

7. Logon to SAP Quality Center by HP. Choose appropriate domain and project.

8. Select the Requirements tab, and expand “Requirements” tree. Right click on the transferred project and select “Expand All” option.

![Requirements tree](image)

Blueprint seen from SAP Quality Center by HP

Tree elements would expand, and tree elements will have icons associated with it.

9. Double click on any tree element for more details.
Link to the document transferred from SAP Solution Manager

<table>
<thead>
<tr>
<th>Icon</th>
<th>Correspondence with SAP Solution Manager</th>
</tr>
</thead>
<tbody>
<tr>
<td>📄 Business Structure</td>
<td>Blueprint Structure from SAP Solution Manager, for example scenarios, processes, sub-processes etc.</td>
</tr>
<tr>
<td>🕰️ Testing Requirement</td>
<td>Test object directly added “Sent to SAP QC by HP” tab or attached to Business requirement document upload in „Sent to SAP QC by HP“ tab.</td>
</tr>
</tbody>
</table>

### 4.3 Send Test Results from SAP Quality Center by HP to SAP Solution Manager

Quality Engineers do test planning, test case writing and execution in SAP Quality Center by HP, and then once execution is over they pass on the result of the testing process to SAP Solution Manager, so that Project Managers, also have a view of testing process.

These steps detail out, how to transfer the status to SAP Solution Manager.

1. Once test execution is over in SAP Quality Center by HP, Click on Tools.
2. Click on „SAP Tools“.
3. Click on „Update Solution Manager“
4. Select the desire blueprint and then click on „Update Blueprint Quality“.
4.4 Filing Defect in SAP Quality Center by HP and sending it to SAP Solution Manager

In the test execution process, whichever defects are reported need to be send to SAP Solution Manager for resolution. Once the defects are resolved, and it's updated by a processor, then it needs to be sent back to SAP Quality Center by HP for verification.

These steps cover process for filing and sending the defect to SAP Solution Manager.

1. Logon to SAP Quality Center by HP. Choose appropriate domain and project.

2. Click on and then click on .

   ![Defect Reporting in SAP Quality Center](image)

3. “Detected By”, “Severity” and “Detected on Date” are mandatory fields.
5. The tested could provide other details like SAP Component, Application System Id, etc.
6. Click on “Submit”.

7. To check the status of defect synchronization, Go to Tools-> SAP Tools-> Manage Defect Synchronization.

8. The new defect has to be assigned to SAP for resolution, for this click on the defect and then right click, and select “Assign Responsibility to SAP”.
4.5 Resolving defect in SAP Solution Manager and Sending it to SAP Quality Center by HP

The steps explain the process of sending defect to SAP Quality Center by HP, once it's fixed.

1. Logon to SAP Solution Manager and start transaction CRM_UI. The CRM Webclient UI is launched, search for the defect by date or component. It is possible to give many search criteria.
2. Open the defect and click on edit button. Note the status of defect which is "Received from HPQC".

3. Click on "Add Text" - > “Reply” in the Text assignment block. Provide certain information

4. Save the Incident.

5. Click on in External Service Desk assignment block to propose a solution.

6. The status is changed to proposed solution in SAP Solution Manager.

7. Logon to SAP Quality Center.

8. Click on tab in SAP Quality Center by HP, and select the defect, check the status which will be “Fixed” and see the description added by processor.

9. Close the defect in SAP Quality Center, and the status of the defect will change to Confirmed in SAP Solution Manager.
4.6 Reporting in SAP Quality Center by HP

The reports and graphs could be generated on the basis of:

- Requirements
- Test Planning
- Test Execution
- Defects

A SAP Quality Center by HP user can see the status of the testing process and other statistics on the basis of requirements by executing the following steps.

1. Logon to SAP Quality Center by HP. Choose appropriate domain and project.

2. Click on Requirements.

3. Select your project and right click on it, and select "Expand All".
Seeing the status of project via requirement tab of SAP Solution Manager

4. The status of each element of tree would be shown like “Not Covered”, “Pass”, etc.
5. Alternatively you may click on, Analysis and select different options.

Analysis tab

Different types of reports

To see the reports and graphs on the basis of Test Planning, the user can execute following steps:-

1. Logon to SAP Quality Center by HP. Choose appropriate domain and project.
2. Click on Test Plan.
3. Analysis and select different options,

- Different type Test Planning Reports
- Different type of Test Execution Reports
- Different types of Defect related Graphs

For test execution and test defects, click on Test lab and Defect tab, and then click on analysis to see different graphs and reports.
4.7 Reporting in SAP Solution Manager

A SAP Solution Manager user could also see status of testing process for his project by executing the following steps.

1. Logon to SAP Solution Manager and go to Work Centers -> Test Management -> Reports. In the reports click on "Test Results for Business Requirement Documents" -> "Testing with SAP Quality Center by HP" -> Reports.

![Image of SAP Solution Manager: Work Centers]

1. Select the desired project and click on ![Project Icon].

![Image of Testing: Test Results of Business Test Requirement]

Selection of a Project

2. Expand the project tree to see the test result for each test object.

![Image of Reporting in SAP Solution Manager]
3. To see result from Business Blue print, Navigate to “Test Management” work center, click on Test Preparation->Project and select the desired project, Click on Goto->Business Blueprint.

4. Expand the project tree and goto process/sub-process where test object is present.

**Reporting in Blueprint**
5. Click on tab “Send to SAP QC by HP”, select the test and click . Choose “Test results” tab to see the results of testing exercise.

Reporting in Blue print
5. Appendix

5.1 Detailed Step for Adapter Configuration

To configure adapter launch SPRO transaction, and click on “SAP Reference IMG”, and navigate to SAP Solution Manager Implementation Guide -> SAP Solution Manager -> Capabilities (Optional) -> Test Management -> External Integration -> SAP Quality Center by HP

![Display IMG](image)

The user performing the IMG activities should have access to the following transactions:

1. LPCONFIG
2. SOAMANAGER
3. SU01
4. PFCG
5. SE16
6. ICTCONF

5.1.1 Integration Test Management

5.1.1.1 Specify Logical Port

1. Choose Web Service Configuration in the Service Administration tab.
2. Enter the following data:
   a. Search for: Consumer Proxy
   b. Search term: CO_AGS_HPQCSMBLUEPRINT_HANDLER
   c. Field: Internal name
3. Start the search.
4. Choose the consumer proxy and Apply Selection.
5. Go to the Configuration tab.
6. Choose Create Logical Port.

7. Enter the required data:
8. Logical Port: <Name of the logical port>
9. URL for WSDL access: <http://<QCServer>:
   <QCServerPort>/EIServer/SMBlueprintHandler?wsdl>

Note: The “EIServer/SMBlueprintHandler?wsdl“ part of URL for WSDL access is case sensitive. To check the validity of the complete URL, kindly paste it in the web browser to see xml information.
10. Select Logical Port as Default.
11. Save.

5.1.1.2 Set-Up Communication User for Quality Center

1. Create a communication user in SAP Quality Center, e.g. qctransfer.

2. Assign the communication user to the SAP Quality Center project which will be linked with solution manager project and also make it admin of the project. This activity can be done in "siteadmin" functionality of SAP Quality Center.
Add SAP QC transfer user to the project

3. Enter the communication user and password, e.g. in SAP Solution Manager.

**Standard User for Communication with HP Quality Center**

<table>
<thead>
<tr>
<th>Communication User</th>
<th>qctransfer</th>
</tr>
</thead>
<tbody>
<tr>
<td>User Password</td>
<td></td>
</tr>
<tr>
<td>Password Status</td>
<td>Set</td>
</tr>
</tbody>
</table>

Add SAP QC transfer user to SAP Solution Manager

**Standard User for Communication with HP Quality Center**

<table>
<thead>
<tr>
<th>Communication User</th>
<th>qctransfer</th>
</tr>
</thead>
<tbody>
<tr>
<td>User Password</td>
<td>************</td>
</tr>
<tr>
<td>Password Status</td>
<td>Initial</td>
</tr>
</tbody>
</table>

Add SAP QC transfer user to SAP Solution Manager

4. Save.

5.1.1.3 Set Up Technical User for Web Service

Create User

1. Specify a user name in the user maintenance.
Create Technical User for web service

User Maintenance: Initial Screen

Create Technical User

2. Choose the user type *Service*.

User type and log on information

3. Enter mandatory details like last name and password for the user, and click on save.

Assign the role to the user

1. Copy the role SAP_QC_INTERFACE to create a custom role, e.g. Z_SAP_QC_INTERFACE. "Copy All" could be used to copy the role.
2. Do following steps to ensure all the authorizations are enabled for the new role, i.e.
   Z_SAP_QC_INTERFACE.
   a. Open the role, i.e. Z_SAP_QC_INTERFACE for edit.
   b. Go to Authorizations tab, and click on “Change Authorization Data”.
   c. Maintain all the authorizations (turn their icon to green) and generate the profile.
Generating profile for a role

3. Before the authorization has been enabled, the authorization tab icon will be yellow. Once the authorization is given, and the profile is generated, the authorization tab icon of the role will change to green.

4. Assign the user to the role and click on “User Comparison”.

Assign user to role

5. The user comparison icon will turn to green once the user comparison is over.

5.1.1.4 Create Technical User for Alias

Create user

1. Enter a user name, e.g.: HPQCALIAS, in the user maintenance.
Create User

2. Choose the user type System.

User type and log on information

3. Give the user a last name (mandatory detail) and password. Click on save.

Assign role to a user

1. Copy the role SAP_QC_WSDL_ACCESS in the role maintenance to create a new custom role, e.g. Z_SAP_QC_WSDL_ACCESS. Open the newly created role, i.e. Z_SAP_QC_WSDL_ACCESS, for editing.
2. Do following steps to ensure all the authorizations are enabled for the new role, i.e. Z_SAP_QC_WSDL_ACCESS.
   a. Open the role, i.e. Z_SAP_QC_WSDL_ACCESS for edit.
   b. Go to Authorizations tab, and click on “Change Authorization Data”.

Role Copy

Edit Role
c. Maintain all the authorizations (turn their icon to green) and generate the profile.
3. Before the authorization has been enabled, the authorization tab icon will be yellow. Once the authorization is given, and the profile is generated, the authorization tab icon of the role will change to green.

4. Assign the user to the role and click on “User Comparison”.

5. The user comparison icon will turn to green once the user comparison is over.

5.1.1.5 Release Web Service for Test Results

1. Choose Web Service Configuration in the Service Administration tab.
2. Enter the following data:
   a. Search for: Service
   b. Search term: AGS_WBS_SOLAR_IF_MERCURY
3. Start the search.
4. Choose the service and Apply Selection.
5. Choose the Configuration tab in the detail screen, and create a service with Create Service.
6. Enter the following data:
   a. Service name: AGS_WBS_SOLAR_IF_MERCURY
   b. Description: AGS_WBS_SOLAR_IF_MERCURY
   c. Binding name: AGS_WBS_SOLAR_IF_MERCURY
7. Choose Apply Settings.

![Service Information](image1)

Create new service

8. Choose the service and Edit, to make security settings.

![Service Configuration](image2)

Edit a service

9. Choose No Authentication in the area Authentication Settings, to assign the technical user.
10. Enter the technical user, e.g. HPQCTechUser and its password under ABAP Service User.

![Authentication Settings](image3)

Giving authentication information for a service

11. Save.
5.1.1.6 Activate Service and Create Alias

Activate the service

You can check whether the individual services are active.

1. Select the hierarchy type SERVICE.
2. Choose service path as /sap/bc/srt/wsdll

```
Maintain Services

Filter for Calling ICF Hierarchy
Hierarchy Type: SERVICE
Virtual Host:
Service Path: /sap/bc/srt/wsdll
```

Search for a service path

3. Click Execute
4. Right click on the service and click on activate.

```
Maintain service

Filter Details
Virtual Host:
Service Path: /sap/bc/srt/wsdll
```

Activate service
Set up alias

5. Select External Aliases.

6. Select default_host, right click and select Create External Alias.

7. Enter the corresponding data:
   - External Alias: /sap/bc/srt/wsdl
   - Description, for example, "QC Management"

8. On the Logon Data tab, choose Required with Logon Data.
9. Specify the user name and password for the http access that you have already created, such as HPQCALIAS.
10. Click on "Trg Element" tab, and select `default_host -> sap -> bc -> srt -> wsdl` from the tree.

11. Save your entries.
5.1.1.7 Activate Service to Display Solution Manager Documents in QC

1. Choose hierarchy type as SERVICE.
2. Select the node “/default_host/sap/bc/solman/SolmanDocuments” in the tree structure.
3. Right click on the node “/default_host/sap/bc/solman/SolmanDocuments” and click on “Activate”.

5.1.1.8 Connect to HP Quality Center

1. Use an existing project.
2. Choose Edit -> Connection to HP Quality Center in the menu.
3. A dialog box with all the data required for the connection to the Quality Center appears.
Connect a Solution Manager project to SAP Quality Center Project

4. Expand Communication Data. The user can select different logical port to connect to different QC. The default user to connect to Quality Center could be changed by clicking on the user button. Press Enter after typing the password. Once the user presses enter, a search in Quality Center is made to display all the projects accessible to the specified user, in a combo box.

Logical Select Port

5. Check the communication user data. You can also specify a different default user.
6. Choose the project in the Quality Center to which you want to establish the connection.
Select a SAP QC project

7. Save.

5.1.1.9 Set-Up Batch Jobs

1. Schedule the reports:
   a. `RS_SM_QC_REQUIREMENT_SYNC` (SAP Solution Manager to Quality Center)
   b. `RS_SM_QC_TESTRESULT_SYNC` (Quality Center to SAP Solution Manager)
   c. Refresh hourly.
<table>
<thead>
<tr>
<th>No.</th>
<th>Program name/command</th>
<th>Prog. type</th>
<th>Spool 71st</th>
<th>Parameters</th>
<th>User</th>
<th>Lang.</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>RS_SM_DC_REQUIREMENT_SYNC</td>
<td>ABAP</td>
<td></td>
<td></td>
<td>I953961</td>
<td>EN</td>
</tr>
<tr>
<td>2</td>
<td>RS_SM_QC_TESTRESULT_SYNC</td>
<td>ABAP</td>
<td></td>
<td></td>
<td>I953961</td>
<td>EN</td>
</tr>
</tbody>
</table>

Reports added to hourly batch job
5.1.2 Integration Defect Management

Perform the activities in the Activities section of this IMG activity.

5.1.2.1 Create Logical Port for Standard Interface

This IMG activity launches LPCONFIG transaction.

1. The transaction may be out of date. Ignore any such messages.
2. Choose proxy class CO_PCICT_SERVICE_DESK_API
3. Specify a logical port
4. Choose Create
5. Enter a description
6. Choose the Call Parameters tab
7. Enter the required data. Enter the following URL in the tab: http://<QCServer>:<QCServerPort>\EIServer\services\ICT_SERVICE_DESK_API?wsdl. Check the URL in the browser to make sure that the URL is right. Click on save.

![Display/Create Logical Port](image1)

**Display/Create Logical Port**

Create logical port for proxy CO_PCICT_SERVICE_DESK_API

![Edit Logical Port](image2)

**Edit Logical Port**

Specify URL for a logical port
Checking URL for a logical port in Web browser

8. Make it active also by clicking on [ ].

Activating a logical port
5.1.2.2 Create Logical Port for Quality Center Extension

This IMG activity launches SOAMANAGER.

1. Choose Web Service Configuration in the Service Administration tab.
2. Enter the following data:
   a. Search by: Consumer Proxy
   b. Search pattern: ICT_SERVICE_DESK_API_MQC
3. Start the search.
4. Select the Consumer Proxy and choose Apply Selection.

5. Choose the Configurations tab.
6. To create the logical port, choose the Create Logical Port pushbutton.
7. Enter the corresponding data in the dialog box that appears.
   a. Logical port: <name of logical port>
   b. URL: <http://<QCServer>:<QCServerPort>/EIServer/services/ICT_SERVICE_DESK_API_MQC?wsdl>
8. Select the field Logical Port is Default.
9. Choose Apply Settings.
10. Save your entries.

5.1.2.3 Create Technical User

This IMG launches SU01 and PFCG transaction.

1. Enter a user name, e.g., QCDEFECTMAN
2. Choose the user type System.
3. Save.
4. Assign role to a user
   a. SAP_SUPPDESK_ADMIN
   b. SAP_SUPPDESK_INTERFACE
5. See section 5.1.1.14 to get details for user creation and role assignment. Kindly note it’s recommended to create a custom role of above SAP roles, and then it’s should be assigned to the user.

5.1.2.4 Release Web Service for External Service Desk

This IMG activity launches SE16 transaction.

1. Select service ICT_SERVICE_DESK_API and variant ICT_SERVICE_DESK_API.
   a. The transaction may be out of date. Ignore any such messages.
2. Choose Create or Web Service -> Create
Create service ICT_SERVICE_DESK_API

3. Save your entries.
4. Start transaction SICF
5. Filter by the Service Path: `/sap/bc/srt/rfc/sap/ICT_SERVICE_DESK_API`

Filter a web service

6. Click on the edit button to see the logon on data tab. On the Logon Data tab, choose required with Logon Data.

Edit a web service
7. Specify the user for the http access that you have already created, such as QCDETECTMAN.

![Create/Change a Service](image1)

**Username and password for a web service**

8. Enter a password.
9. Save your entries.

5.1.2.5 **Release Web Service for Enhanced Service Desk Interface**

This IMG activity launches SOAMANGER.

1. Choose **Web Service Configuration** in the **Service Administration** tab.
2. Enter the following data:
   a. Search for: Service
   b. Search term: ICT_SERVICE_DESK_API_MQC
3. Start the search.
4. Select the service and choose Apply Selection.

![Web Service Administration](image2)

**Search for service ICT_SERVICE_DESK_API_MQC**
5. Choose the Configuration tab in the detail screen, and create a service with Create Service.
6. Enter the following data:
   a. Service name: ICT_SERVICE_DESK_API_MQC
   b. Description: ICT_SERVICE_DESK_API_MQC
   c. Binding name: ICT_SERVICE_DESK_API_MQC
7. Confirm your entries with Copy Settings.

8. Choose your service, and Edit, to make the security settings.
9. Select No Authentication under Authentication Settings, to assign the communication user, i.e. QCDEFECTMAN
10. Enter the communication user and its password under ABAP Service User.
11. Save.
5.1.2.6 Configure Interface

This IMG activity launches ICTCONF transaction.

1. Choose Add.
2. Enter a name for the external service desk system.
3. Select the logical port which you created in a previous step.
4. Apply the entries.
   The system automatically calls the external service desk system. Following a successful call, the system reads the service desk ID of the service desk and displays it in the list.
5. Choose the type of the external service desk.
6. Choose the method for determining the reporter.
   
   o New BP if none with same e-mail address exists: The system creates a new business partner if one cannot be identified unambiguously from the e-mail address.
   o BP of the system user: The system uses the business partner of the RFC user as the reporter
   o No BP entered as reporter: If the field remains empty, the message is not assigned to a reporter
   o Only BP with same e-mail address as reporter: The system assigns no business partner as reporter if one cannot be identified unambiguously from the e-mail address.
Check “Automatically synchronise” if you wish information from SAP Solution Manager to be automatically updated in SAP Quality Center.

7. Click continue button.
8. Select the following row.
9. Click on “Overwrite old values”.
10. Press Save
11. Make the interface Active by clicking on the button.

5.1.2.7 Adapt Status Profile for Transaction Type SMIN

1. Select the transaction type SMIN.
2. Search for SMIN
   - Select the status schema SMINHPQC from the value help for the field Status Profile, to assign the new status schema.
5.1.2.8 Assign Web Service Configuration to External Test Tool

You have finalized all steps related to the configuration of logical ports and endpoints which are required to use the adapter.

As a result you should have the following objects:

- Logical port for test management - 2 logical ports for defect management (standard + extended)
- Endpoint for test management - 2 endpoints for defect management (standard + extended)

In this IMG activity, do the following:

- Assign the corresponding end point for QC to call back (Test Management)
- Assign the corresponding ports and endpoints for the defect integration.
5.1.2.9 Assign Fields and Values in Quality Center System
See section 3.3.

5.1.2.10 Schedule Background Job for System Synchronization
Schedule report AGS_HPOC_PUSH_COMPONENTS. If you do not specify a project when you schedule, the system synchronizes all projects that are linked to a Quality Center project.

5.1.2.11 Define Extended Interface Mapping for Service Desk Customizing

1. Go to IMG activity present in the Application Incident Management group, as highlighted in the below picture.

2. Set the values as highlighted below
## Change View "SM SD Interface: System Configuration": Overview

<table>
<thead>
<tr>
<th>Trans. Type</th>
<th>External Service</th>
<th>Attribute</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>184A869B0FEC11D</td>
<td>HPDL_QC</td>
<td>Status Value for Message</td>
<td>E0011SMINHPQC</td>
</tr>
<tr>
<td>184A869B0FEC11D</td>
<td>HPRC_QC</td>
<td>Status Value for Confi...</td>
<td>E0008SMINHPQC</td>
</tr>
<tr>
<td>184A869B0FEC11D</td>
<td>HPRC_QC</td>
<td>Status Value for Sent O...</td>
<td>E0011SMINHPQC</td>
</tr>
<tr>
<td>184A869B0FEC11D</td>
<td>HPRC_QC</td>
<td>Status Value for Sent P...</td>
<td>E0005SMINHPQC</td>
</tr>
<tr>
<td>184A869B0FEC11D</td>
<td>HPRC_QC</td>
<td>Status Value for Initial</td>
<td>E0010SMINHPQC</td>
</tr>
<tr>
<td>184A869B0FEC11D</td>
<td>HPDL_QC</td>
<td>Activate/Deactivate Tra...</td>
<td>X</td>
</tr>
<tr>
<td>SMT</td>
<td>184A869B0FEC11D</td>
<td>HPDL_QC</td>
<td>E0012SMINHPQC</td>
</tr>
<tr>
<td>SMT</td>
<td>184A869B0FEC11D</td>
<td>HPRC_QC</td>
<td>E0011SMINHPQC</td>
</tr>
<tr>
<td>SMT</td>
<td>184A869B0FEC11D</td>
<td>HPRC_QC</td>
<td>E0010SMINHPQC</td>
</tr>
<tr>
<td>SMT</td>
<td>184A869B0FEC11D</td>
<td>HPRC_QC</td>
<td>E0005SMINHPQC</td>
</tr>
<tr>
<td>SMT</td>
<td>184A869B0FEC11D</td>
<td>Status Value for Message</td>
<td>E0011SMINHPQC</td>
</tr>
<tr>
<td>SMT</td>
<td>184A869B0FEC11D</td>
<td>Status Value for Confi...</td>
<td>E0008SMINHPQC</td>
</tr>
<tr>
<td>SMT</td>
<td>184A869B0FEC11D</td>
<td>Status Value for Sent O...</td>
<td>E0011SMINHPQC</td>
</tr>
<tr>
<td>SMT</td>
<td>184A869B0FEC11D</td>
<td>Status Value for Sent P...</td>
<td>E0005SMINHPQC</td>
</tr>
<tr>
<td>SMT</td>
<td>184A869B0FEC11D</td>
<td>Status Value for Initial</td>
<td>E0010SMINHPQC</td>
</tr>
</tbody>
</table>
# 5.2 Adapter Configuration Checklist

<table>
<thead>
<tr>
<th>Integration Test Management</th>
<th>Status</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Logical port</strong> &lt;http://&lt;QCServer&gt;:&lt;QCServerPort&gt;/EIServer/SMBlueprintHandler?wsdl&gt; is created.</td>
<td>1</td>
</tr>
<tr>
<td><strong>Set up communication user, a user with proper authorization should be created in SAP QC and should be configured in IMG settings.</strong></td>
<td>2</td>
</tr>
</tbody>
</table>
| **Technical user for the webservice, e.g. HPQCTechUser is created with proper roles.**  
- A user e.g. HPQCTechUser of type service is created.  
- The roles SAP_QC_INTERFACE  with all authorizations in green is assigned to the user  
- User comparison and Profile generation is done for the role, i.e. SAP_QC_INTERFACE | 3 |
| **Technical user for the alias e.g. HPQCALIAS is created with proper roles.**  
- A user e.g. HPQCALIAS of type service is created.  
- The roles SAP_QC_WSDL_ACCESS  with all authorizations in green is assigned to the user  
- User comparison and Profile generation is done for the role, i.e. SAP_QC_INTERFACE | 4 |
| **AGS_WBS_SOLAR_IF_MERCURY is released with ABAP Service user set to HPQCTechUser.** | 5 |
| **Activate service /sap/bc/srt/wsd1 and create external alias with proper log on data, i.e HPQCALIAS** | 6 |
| **Activate Service to Display Solution Manager Documents in QC** | 7 |
| **Connect SAP Solution Manager project with SAP Quality Center Project**  
- Choose correct logical port  
- Choose correct username/password to access SAP QC  
- Choose correct SAP QC Project | 8 |
| **Set up batch jobs**  
- `RS_SM_QC_REQUIREMENT_SYNC`  
- `RS_SM_QC_TESTRESULT_SYNC` | 9 |
<table>
<thead>
<tr>
<th>Integration Defect Management</th>
<th>Status</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Configuration</strong></td>
<td></td>
</tr>
<tr>
<td>Make the interface, e.g. Connect to Twdf1207 QC ..., <strong>Active</strong>.</td>
<td></td>
</tr>
<tr>
<td>Create logical port with proxy class CO_PCICRT_SERVICE_DESK_API and url: http://&lt;QCServer&gt;: &lt;QCServerPort&gt;//EIServer/services/ICT_SERVICE_DESK_API?wsdl</td>
<td></td>
</tr>
<tr>
<td>Activate the logical port</td>
<td></td>
</tr>
<tr>
<td>Create logical port with proxy class ICT_SERVICE_DESK_API_MQC and url: http://&lt;QCServer&gt;: &lt;QCServerPort&gt;//EIServer/services/ICT_SERVICE_DESK_API_MQC?wsdl</td>
<td></td>
</tr>
<tr>
<td>Activate the logical port</td>
<td></td>
</tr>
<tr>
<td>Create User with specified roles</td>
<td></td>
</tr>
<tr>
<td>- Create user e.g QCDEFEHMAM with user type system</td>
<td></td>
</tr>
<tr>
<td>- Assign roles Z_SAP_SUPPDESK_ADMIN and Z_SAP_SUPPDESK_INTERFACE</td>
<td></td>
</tr>
<tr>
<td>- User comparision and profile is generated for each role</td>
<td></td>
</tr>
<tr>
<td>Release web service ICT_SERVICE_DESK_API with logon date i.e. QCDEFEHMAM</td>
<td></td>
</tr>
<tr>
<td>Release web service ICT_SERVICE_DESK_API_MQC with logon date i.e. QCDEFEHMAM</td>
<td></td>
</tr>
<tr>
<td>Configure interface for previous logical port, with Overwrite old values option</td>
<td></td>
</tr>
<tr>
<td>Adapt Status Profile for Transaction Type SMIN</td>
<td></td>
</tr>
<tr>
<td>Assign Web Service Configuration to External Test Tool</td>
<td></td>
</tr>
<tr>
<td>Do field mapping for defect exchange in SAP QC, and enable append only mode.</td>
<td></td>
</tr>
<tr>
<td>Schedule background job for synchronization</td>
<td></td>
</tr>
<tr>
<td>Set the values in the Service Desk Customizing</td>
<td></td>
</tr>
</tbody>
</table>
5.3 Assignment of user to SAP Quality Center by HP project

1. Go to SAP Quality Center by HP URL, and click on "Site Administrator".
2. Logon using administrator user.
3. By default you would be seeing list of projects otherwise click on “Site Projects”.
4. Select your project and then click on “Project Users”.

Adding users to a project

5. Click on “Add”, and then select and add users to this project.
6. If this user needs to file defect, do test planning, etc then this user should be project administrator. This user could be project administrator by clicking on the check box under “Project administrator” column.
5.4 Solution Manager Blueprint Trash in SAP Quality Center by HP

Whenever there is update from SAP Solution Manager to SAP Quality Center by HP, the old blueprint structure and content is pushed to Solution Manager Blueprints Trash folder. These steps explain how to view the contents of the Solution Manager Blueprints Trash folder.

1. Go to . Click on Solution Manager Blueprints Trash folder and expand it.
2. In the following image, we would notice that only the element which is changed is moved, and rest of the blueprint is not backed up.

Blueprint Trash Folder
5.5 Mapping new fields for defects exchange

To add the new fields SolMan side, you need to follow the instructions in the note 1566507

1. Field Mapping

To define the set of available SAP fields from Solution Manager side start the report AGS_HPQC_INIT. Choose the GUID for the corresponding external HP-QC system from the search help. To add new fields select the 'Insert' option. If you want to change existing entries select 'Edit'. Activate the 'Update' flag to ensure that all changes are committed to the database.

2. Value Mapping

To define a fixed set of values for one SAP field on Solution Manager side use transaction SM30 and maintain table ICT_MAP_ADDATTR. For each value enter a unique identifier, select the GUID for the external HP-QC system from the search help, enter the name of the Corresponding field and choose direction outbound. Use the same value for internal and external values if you do not want any mapping to be applied. Make sure that the value is set for both - internal and external value.

5.6 Relevant Notes

1566507 New field mapping
1109650 SAP Solution Manager 4.0 Extensions Add-Ons
1059350 Installing SAP Adapter for SAP Quality Center by HP
1337573 No test results for test objects directly assigned to a node

5.7 Troubleshooting Adapter

Verify that the following tables and columns are created in QC DB.

Table Name="BUG"

  Column Name = BG_EI_GUID
  Column Name = BG_EI_EXTERNAL_GUID
  Column Name = BG_EI_APP_ID
  Column Name = BG_EI_APP_COMP
  Column Name = BG_EI_APP_CLIENT
  Column Name = BG_EI_APP_SYS_ID
  Column Name = BG_EI_LANG
  Column Name = BG_EI_DEFECT_TYPE
  Column Name = BG_EI_RESPONSIBILITY
  Column Name = BG_EI_FORCE_CLOSE
  Column Name = BG_EI_TRANSFERRED_REQ
  Column Name = BG_EI_TRANSFERRED_TEST
  Column Name = BG_EI_OLD_VALUES

Table Name="BLUEPRINTS"

  Column Name = SPI_BL_ID
  Column Name = SPI_BL_REQ_ID
Column Name = SPI_BL_APP_ID
Column Name = SPI_BL_SM_PROJ_ID
Column Name = SPI_BL_SM_URL
Column Name = SPI_SD_SM_URL
Column Name = SPI_ADD_SD_SM_URL
Column Name = SPI_BL_UPDATE_STAT
Column Name = SPI_BL_LAST_SYNC_T
Column Name = SPI_BL_PUSH_BP_URL
Column Name = SPI_BL_EXTERNAL_GUID

Table Name="EI_FIELD_MAPPING"
Column Name = EI_FM_MAP_ID
Column Name = EI_FM_APP_ID
Column Name = EI_FM_EXTERNAL_NAME
Column Name = EI_FM_EXTERNAL_LABEL
Column Name = EI_FM_EXTERNAL_IS_REQUIRED
Column Name = EI_FM_EXTERNAL_TYPE
Column Name = EI_FM_EXTERNAL_SIZE
Column Name = EI_FM_MAPPING_TYPE
Column Name = EI_FM_QC_FIELD_NAME

Table Name="EI_FIELD_VAL_MAPPING"
Column Name = EI_FVM_VAL_ID
Column Name = EI_FVM_MAP_ID
Column Name = EI_FVM_EXTERNAL_VALUE
Column Name = EI_FVM_EXTERNAL_LABEL
Column Name = EI_FVM_QC_VALUE
Column Name = EI_FVM_QC_LABEL

Table Name="EI_SYNC_POOL"
Column Name = EI_SP_ENTITY_ID
Column Name = EI_SP_REL_ENTITY_ID
Column Name = EI_SP_REL_ENTITY_TYPE
Column Name = EI_SP_EXTERNAL_ID
Column Name = EI_SP_SYNC_STATUS
Column Name = EI_SP_INSERTION_TIME
Column Name = EI_SP_SYNC_TRY_COUNT
Column Name = EI_SP_ADDITIONAL_DATA

Table Name="REQ"
Column Name = RQ_SM_REQ_ID
Column Name = RQ_SM_NODE_ID
Column Name = RQ_SM_KEYWORDS
<table>
<thead>
<tr>
<th>Column Name</th>
<th>Table Name</th>
</tr>
</thead>
<tbody>
<tr>
<td>RQ_SM_OBJ_CODE</td>
<td>CROS_REF</td>
</tr>
<tr>
<td>RQ_SM_T_LOG_COMP</td>
<td></td>
</tr>
<tr>
<td>RQ_SM_REL_OBJ_TYPE</td>
<td></td>
</tr>
<tr>
<td>CR_EI_GUID</td>
<td></td>
</tr>
<tr>
<td>CR_EI_PUBLISHED</td>
<td></td>
</tr>
</tbody>
</table>
5.8 Additional Information

1. Link to learning map: [www.service.sap.com/rkt-solman](http://www.service.sap.com/rkt-solman) -> SAP Solution Manager Extensions -> SAP Solution Manager adapter for SAP Quality Center by HP

2. Link to learning map: [www.service.sap.com/rkt-solman](http://www.service.sap.com/rkt-solman) -> SAP Solution Manager 7.0 - Enhancement Package 1 (EHP1)

3. Link to learning map: [www.service.sap.com/rkt-solman](http://www.service.sap.com/rkt-solman) -> SAP Solution Manager Extensions -> SAP Test Acceleration and Optimization (SAP TAO)

4. Link to Solution Manager: [www.service.sap.com/solutionmanager](http://www.service.sap.com/solutionmanager)